Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 19, 2025 - 20:00 CDT
Scheduled
Routine maintenance to patch Windows servers for the Microsoft Vulnerability CVE-2025-33053. Installing patch and then rebooting. Should be roughly 30 minutes, however, 2 hours have been scheduled for the maintenance window.
Posted Jun 18, 2025 - 09:03 CDT
This scheduled maintenance affected: CCC Managed Web Applications (Report Server, Biospecimen, Protocols & Consents, Web Resources (webres.uccrc.org), Priority Tree, WebAppAdmin, diseasecodeentry) and Internal Services (WebAPI).